CVE-2018-11778

High

Description

UnixAuthenticationService in Apache Ranger 1.2.0 was updated to correctly handle user input to avoid Stack-based buffer overflow. Versions prior to 1.2.0 should be upgraded to 1.2.0

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Ranger
PublishedOct 5, 2018
First seenOct 5, 2018

How to fix

Update
  • apache ranger1.2.0 or later
  • org.apache.ranger:ranger1.2.0 or later

Affected products

ProductAffected versionsFixed in
apache rangerv < 1.2.01.2.0
org.apache.ranger:rangerMavenv < 1.2.01.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2018-11778 · Apache Ranger · Dark Radar