CVE-2018-11796
Description
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.
How to fix
- org.apache.tika:tika-core1.19.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tika | 0.1 ≤ v ≤ 1.19 | — |
| org.apache.tika:tika-coreMaven | 0.1 ≤ v < 1.19.1 | 1.19.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.