CVE-2018-1327
Description
The Apache Struts REST Plugin is using XStream library which is vulnerable and allow perform a DoS attack when using a malicious request with specially crafted XML payload. Upgrade to the Apache Struts version 2.5.16 and switch to an optional Jackson XML handler as described here http://struts.apache.org/plugins/rest/#custom-contenttypehandlers. Another option is to implement a custom XML handler based on the Jackson XML handler from the Apache Struts 2.5.16.
How to fix
- org.apache.struts:struts2-rest-plugin2.5.16 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache struts | 2.1.1 ≤ v ≤ 2.5.14.1 | — |
| org.apache.struts:struts2-rest-pluginMaven | 2.1.1 ≤ v < 2.5.16 | 2.5.16 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.