CVE-2018-1335
High
Description
From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used to inject commands into the command line of the server running tika-server. This vulnerability only affects those running tika-server on a server that is open to untrusted clients. The mitigation is to upgrade to Tika 1.18.
SeverityHigh
CVSS8.1
Exploit probability—
Product
Apache Tika
PublishedApr 25, 2018
First seenApr 25, 2018
How to fix
Update
- apache tika1.18 or later
- org.apache.tika:tika-core1.18 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tika | v < 1.18 | 1.18 |
| org.apache.tika:tika-coreMaven | 1.7 ≤ v < 1.18 | 1.18 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.