CVE-2018-16854

Medium

Description

A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.

SeverityMedium
CVSS6.5
Exploit probability—
ProductMoodle
PublishedNov 26, 2018
First seenNov 26, 2018

How to fix

Update
  • moodle moodle3.1.15, 3.3.9, 3.4.6, 3.5.3 or later
  • moodle/moodle3.1.15, 3.3.9, 3.4.6, 3.5.3 or later

Affected products

ProductAffected versionsFixed in
moodle moodlev ≤ 3.0.10, 3.1.0 ≤ v < 3.1.15, 3.3.0 ≤ v < 3.3.9, 3.4.0 ≤ v < 3.4.6, 3.5.0 ≤ v < 3.5.33.1.15, 3.3.9, 3.4.6, 3.5.3
moodle/moodlePackagist3.1 ≤ v < 3.1.15, 3.3 ≤ v < 3.3.9, 3.4 ≤ v < 3.4.6, 3.5 ≤ v < 3.5.33.1.15, 3.3.9, 3.4.6, 3.5.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.