CVE-2018-17196
High
Description
In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apache Kafka
PublishedJul 11, 2019
First seenJul 11, 2019
How to fix
Update
- org.apache.kafka:kafka2.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache kafka | 0.11.0.0 ≤ v ≤ 2.1.0 | — |
| org.apache.kafka:kafkaMaven | 0.11.0.0 ≤ v < 2.1.1 | 2.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.