CVE-2018-9243

Medium

Description

GitLab Community and Enterprise Editions version 8.4 up to 10.4 are vulnerable to XSS because a lack of input validation in the merge request component leads to cross site scripting (specifically, filenames in changes tabs of merge requests). This is fixed in 10.6.3, 10.5.7, and 10.4.7.

SeverityMedium
CVSS6.1
Exploit probability—
ProductGitlab
PublishedApr 5, 2018
First seenApr 5, 2018

How to fix

Update
  • gitlab gitlab10.4.7, 10.5.7, 10.6.3 or later

Affected products

ProductAffected versionsFixed in
gitlab gitlab8.4 ≤ v < 10.4.7, 10.5.0 ≤ v < 10.5.7, 10.6.0 ≤ v < 10.6.310.4.7, 10.5.7, 10.6.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.