CVE-2018-9861
Medium
Description
Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Ckeditor Enhanced Image
PublishedApr 19, 2018
First seenApr 19, 2018
How to fix
Update
- ckeditor enhanced_image4.9.2 or later
- drupal drupal8.4.7, 8.5.2 or later
- drupal/core8.5.2, 8.4.7 or later
- ckeditor-dev4.9.2 or later
- drupal/drupal8.4.7, 8.5.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ckeditor enhanced_image | 4.5.10 ≤ v < 4.9.2 | 4.9.2 |
| drupal drupal | 8.0.0 ≤ v < 8.4.7, 8.5.0 ≤ v < 8.5.2 | 8.4.7, 8.5.2 |
| drupal/corePackagist | 8.5.0 ≤ v < 8.5.2, 8.0 ≤ v < 8.4.7, 8.0.0 ≤ v < 8.4.7 | 8.5.2, 8.4.7 |
| ckeditor-devnpm | 4.5.10 ≤ v < 4.9.2 | 4.9.2 |
| drupal/drupalPackagist | 8.0 ≤ v < 8.4.7, 8.5 ≤ v < 8.5.2 | 8.4.7, 8.5.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.