CVE-2019-0226

Medium

Description

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

SeverityMedium
CVSS4.9
Exploit probability—
ProductApache Karaf
PublishedMay 9, 2019
First seenMay 9, 2019

How to fix

Update
  • apache karaf4.2.5 or later
  • org.apache.karaf.config:org.apache.karaf.config.core4.2.5 or later

Affected products

ProductAffected versionsFixed in
apache karafv < 4.2.54.2.5
org.apache.karaf.config:org.apache.karaf.config.coreMavenv < 4.2.54.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.