CVE-2019-1000002
Description
Gitea version 1.6.2 and earlier contains a Incorrect Access Control vulnerability in Delete/Edit file functionallity that can result in the attacker deleting files outside the repository he/she has access to. This attack appears to be exploitable via the attacker must get write access to "any" repository including self-created ones.. This vulnerability appears to have been fixed in 1.6.3, 1.7.0-rc2.
How to fix
- code.gitea.io/gitea1.6.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| gitea gitea | v ≤ 1.6.2 | — |
| code.gitea.io/giteaGo | v < 1.6.3 | 1.6.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.