CVE-2019-10088
High
Description
A carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Users should upgrade to 1.22 or later.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apache Tika
PublishedAug 2, 2019
First seenAug 2, 2019
How to fix
Update
- org.apache.tika:tika-core1.22 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tika | 1.7 ≤ v ≤ 1.21 | — |
| org.apache.tika:tika-coreMaven | 1.7 ≤ v < 1.22 | 1.22 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.