CVE-2019-1010161

Critical

Description

perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.

SeverityCritical
CVSS9.8
Exploit probability—
ProductPerl-crypt-jwt
PublishedJul 25, 2019
First seenJul 25, 2019

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
perl-crypt-jwt_project perl-crypt-jwtv ≤ 0.022—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2019-1010161 · Perl-crypt-jwt · Dark Radar