CVE-2019-1010266

Medium

Description

lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.

SeverityMedium
CVSS6.5
Exploit probability—
ProductLodash
PublishedJul 17, 2019
First seenJul 17, 2019

How to fix

Update
  • lodash lodash4.17.11 or later
  • lodash4.17.11 or later
  • lodash-es4.17.11 or later
  • lodash-amd4.17.11 or later
  • lodash-rails4.17.11 or later

Affected products

ProductAffected versionsFixed in
lodash lodashv < 4.17.114.17.11
lodashnpm4.7.0 ≤ v < 4.17.114.17.11
lodash-esnpm4.7.0 ≤ v < 4.17.114.17.11
lodash-amdnpm4.7.0 ≤ v < 4.17.114.17.11
lodash-railsRubyGems4.7.0 ≤ v < 4.17.114.17.11

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.