CVE-2019-10240

High

Description

Eclipse hawkBit versions prior to 0.3.0M2 resolved Maven build artifacts for the Vaadin based UI over HTTP instead of HTTPS. Any of these dependent artifacts could have been maliciously compromised by a MITM attack. Hence produced build artifacts of hawkBit might be infected.

SeverityHigh
CVSS8.1
Exploit probability—
ProductEclipse Hawkbit
PublishedApr 3, 2019
First seenApr 3, 2019

How to fix

Update
  • org.eclipse.hawkbit:hawkbit-autoconfigure0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-ui0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-parent0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-starters0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-boot-starter0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-update-server0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-ui0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-api0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-boot-starter-dmf-api0.3.0M2 or later
  • org.eclipse.hawkbit:hawkbit-boot-starter-ddi-api0.3.0M2 or later

Affected products

ProductAffected versionsFixed in
eclipse hawkbitv ≤ 0.2.5, 0.3.0—
org.eclipse.hawkbit:hawkbit-autoconfigureMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-uiMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-parentMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-startersMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-boot-starterMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-update-serverMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-uiMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-apiMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-boot-starter-dmf-apiMavenv < 0.3.0M20.3.0M2
org.eclipse.hawkbit:hawkbit-boot-starter-ddi-apiMavenv < 0.3.0M20.3.0M2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.