CVE-2019-12472
High
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Mediawiki
PublishedJul 10, 2019
First seenJul 10, 2019
How to fix
Update
- mediawiki mediawiki1.27.6, 1.30.2, 1.31.2, 1.32.2 or later
- mediawiki/core1.27.6, 1.30.2, 1.31.2, 1.32.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| mediawiki mediawiki | 1.18.0 ≤ v < 1.27.6, 1.30.0 ≤ v < 1.30.2, 1.31.0 ≤ v < 1.31.2, 1.32.0 ≤ v < 1.32.2 | 1.27.6, 1.30.2, 1.31.2, 1.32.2 |
| mediawiki/corePackagist | 1.18.0 ≤ v < 1.27.6, 1.30.0 ≤ v < 1.30.2, 1.31.0 ≤ v < 1.31.2, 1.32.0 ≤ v < 1.32.2 | 1.27.6, 1.30.2, 1.31.2, 1.32.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.