CVE-2019-15795

Medium

Description

python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

SeverityMedium
CVSS4.7
Exploit probability—
ProductUbuntu Python-apt
PublishedMar 26, 2020
First seenMar 26, 2020
Weakness typeCWE-327CWE-327

How to fix

Update
  • python-apt0.8.3ubuntu7.5, 0.9.3.5ubuntu3, 1.1.0, 1.6.5ubuntu0.1, 1.9.0ubuntu1.2 or later

Affected products

ProductAffected versionsFixed in
ubuntu python-apt0.8.0, 0.8.1, 0.8.3, 0.8.9.1, 0.9.0, 0.9.1, 0.9.3.1, 0.9.3.2, 0.9.3.3, 0.9.3.4, 0.9.3.5, 1.0.1, 1.1.0, 1.4.0, 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.8.4, 1.9.0, 1.7.0, 1.8.0, 1.8.1, 1.8.2, 1.8.3—
debian python-apt1.8.4—
python-aptPyPIv < 0.8.3ubuntu7.5, 0.9.0 ≤ v < 0.9.3.5ubuntu3, 1.0.0 ≤ v < 1.1.0, 1.2.0 ≤ v < 1.6.5ubuntu0.1, 1.7.0 ≤ v < 1.9.0ubuntu1.20.8.3ubuntu7.5, 0.9.3.5ubuntu3, 1.1.0, 1.6.5ubuntu0.1, 1.9.0ubuntu1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.