CVE-2019-16770
Description
In Puma before versions 3.12.2 and 4.3.1, a poorly-behaved client could use keepalive requests to monopolize Puma's reactor and create a denial of service attack. If more keepalive connections to Puma are opened than there are threads available, additional connections will wait permanently if the attacker sends requests frequently enough. This vulnerability is patched in Puma 4.3.1 and 3.12.2.
How to fix
- puma puma3.12.2, 4.3.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| puma puma | 3.0.0 ≤ v < 3.12.2, 4.0.0 ≤ v < 4.3.1 | 3.12.2, 4.3.1 |
| debian debian_linux | 9.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.