CVE-2019-16780

Medium

Description

WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.

SeverityMedium
CVSS5.8
Exploit probability—
ProductWordpress
PublishedDec 26, 2019
First seenDec 26, 2019

How to fix

Update
  • wordpress wordpress5.3.1 or later

Affected products

ProductAffected versionsFixed in
wordpress wordpress3.7 < v < 5.3.1, 3.75.3.1
debian debian_linux9.0, 10.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2019-16780 · Wordpress · Dark Radar