CVE-2019-25158

Medium

Description

A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.

SeverityMedium
CVSS5.5
Exploit probability—
ProductPedroetb Tts-api
PublishedDec 19, 2023
First seenDec 19, 2023

How to fix

Affected products

ProductAffected versionsFixed in
pedroetb tts-apiv < 2.2.02.2.0
tts-apinpmv < 2.2.02.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.