CVE-2019-3394
Description
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under <install-directory>/confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sensitive information such as LDAP credentials. The LDAP credential will be potentially leaked only if the Confluence server is configured to use LDAP as user repository. All versions of Confluence Server from 6.1.0 before 6.6.16 (the fixed version for 6.6.x), from 6.7.0 before 6.13.7 (the fixed version for 6.13.x), and from 6.14.0 before 6.15.8 (the fixed version for 6.15.x) are affected by this vulnerability.
How to fix
- atlassian confluence6.6.16, 6.13.7 or later
- atlassian confluence_server6.15.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| atlassian confluence | 6.1.0 ≤ v < 6.6.16, 6.7.0 ≤ v < 6.13.7 | 6.6.16, 6.13.7 |
| atlassian confluence_server | 6.14.0 ≤ v < 6.15.8 | 6.15.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.