CVE-2019-7139
Critical
Description
An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Magento
PublishedApr 10, 2019
First seenApr 10, 2019
How to fix
Update
- magento magento1.9.4.1, 1.14.4.1, 2.1.17, 2.2.8, 2.3.1 or later
- magento/community-edition2.1.18, 2.2.9, 2.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| magento magento | v < 1.9.4.1, 1.14.0.0 ≤ v < 1.14.4.1, 2.1.0 ≤ v < 2.1.17, 2.2.0 ≤ v < 2.2.8, 2.3.0 ≤ v < 2.3.1 | 1.9.4.1, 1.14.4.1, 2.1.17, 2.2.8, 2.3.1 |
| magento/community-editionPackagist | 2.1.0 ≤ v < 2.1.18, 2.2.0 ≤ v < 2.2.9, 2.3.0 ≤ v < 2.3.2 | 2.1.18, 2.2.9, 2.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.