CVE-2020-10018
Critical
Description
WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Webkitgtk
PublishedMar 2, 2020
First seenMar 2, 2020
How to fix
Update
- webkitgtk webkitgtk2.28.0 or later
- wpewebkit wpe_webkit2.28.0 or later
Vendor advisories
- debian.org/security/2020/dsa-4641
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GLERWAS2LL7SX2GHA2DDZ2PL3QC5OHIF/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DOR5LPL4UASVAR76EIHCL4O2KGDWGC6K/
- usn.ubuntu.com/4310-1/
- security.gentoo.org/glsa/202006-08
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| webkitgtk webkitgtk | v < 2.28.0 | 2.28.0 |
| wpewebkit wpe_webkit | v < 2.28.0 | 2.28.0 |
| fedoraproject fedora | 30, 31 | — |
| debian debian_linux | 10.0 | — |
| canonical ubuntu_linux | 18.04, 19.10 | — |
| opensuse leap | 15.1 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.