CVE-2020-10516
Description
An improper access control vulnerability was identified in the GitHub Enterprise Server API that allowed an organization member to escalate permissions and gain access to unauthorized repositories within an organization. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.21 and was fixed in 2.20.9, 2.19.15, and 2.18.20. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github github2.18.20, 2.19.15, 2.20.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github github | 2.18.0 ≤ v < 2.18.20, 2.19.0 ≤ v < 2.19.15, 2.20.0 ≤ v < 2.20.9 | 2.18.20, 2.19.15, 2.20.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.