CVE-2020-10518

High

Description

A remote code execution vulnerability was identified in GitHub Enterprise Server that could be exploited when building a GitHub Pages site. User-controlled configuration of the underlying parsers used by GitHub Pages were not sufficiently restricted and made it possible to execute commands on the GitHub Enterprise Server instance. To exploit this vulnerability, an attacker would need permission to create and build a GitHub Pages site on the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.22 and was fixed in 2.21.6, 2.20.15, and 2.19.21. The underlying issues contributing to this vulnerability were identified both internally and through the GitHub Security Bug Bounty program.

SeverityHigh
CVSS8.8
Exploit probability—
ProductGithub
PublishedAug 27, 2020
First seenAug 27, 2020

How to fix

Update
  • github github2.19.21, 2.20.15, 2.21.6 or later

Affected products

ProductAffected versionsFixed in
github githubv < 2.19.21, 2.20.0 ≤ v < 2.20.15, 2.21.0 ≤ v < 2.21.62.19.21, 2.20.15, 2.21.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.