CVE-2020-10519
Description
A remote code execution vulnerability was identified in GitHub Enterprise Server that could be exploited when building a GitHub Pages site. User-controlled configuration of the underlying parsers used by GitHub Pages were not sufficiently restricted and made it possible to execute commands on the GitHub Enterprise Server instance. To exploit this vulnerability, an attacker would need permission to create and build a GitHub Pages site on the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.22.7 and was fixed in 2.22.7, 2.21.15, and 2.20.24. The underlying issues contributing to this vulnerability were identified through the GitHub Security Bug Bounty program.
How to fix
- github github2.20.24, 2.21.15, 2.22.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github github | v < 2.20.24, 2.21.0 ≤ v < 2.21.15, 2.22.0 ≤ v < 2.22.7 | 2.20.24, 2.21.15, 2.22.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.