CVE-2020-10944
Medium
Description
HashiCorp Nomad and Nomad Enterprise up to 0.10.4 contained a cross-site scripting vulnerability such that files from a malicious workload could cause arbitrary JavaScript to execute in the web UI. Fixed in 0.10.5.
SeverityMedium
CVSS5.4
Exploit probability—
ProductHashicorp Nomad
PublishedApr 28, 2020
First seenApr 28, 2020
How to fix
Update
- hashicorp nomad0.10.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp nomad | 0.3 ≤ v < 0.10.5 | 0.10.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.