CVE-2020-10946

Medium

Description

Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web script or HTML via the page parameter to service-monitoring/src/index.php. This vulnerability is fixed in versions 1.6.4, 18.10.3, 19.04.3, and 19.0.1 of the Centreon host-monitoring widget; 1.6.4, 18.10.5, 19.04.3, 19.10.2 of the Centreon service-monitoring widget; and 1.0.3, 18.10.1, 19.04.1, 19.10.1 of the Centreon tactical-overview widget.

SeverityMedium
CVSS6.1
Exploit probability—
ProductCentreon Host-monitoring Widget
PublishedMay 27, 2020
First seenMay 27, 2020

How to fix

Update
  • centreon centreon_host-monitoring_widget1.6.4, 18.10.3, 19.0.1, 19.04.3 or later
  • centreon centreon_tactical-overview_widget1.0.3, 18.10.1, 19.04.1, 19.10.1 or later
  • centreon centreon_service-monitoring_widget1.6.4, 18.10.5, 19.04.3, 19.10.2 or later

Affected products

ProductAffected versionsFixed in
centreon centreon_host-monitoring_widgetv < 1.6.4, 18.10.0 ≤ v < 18.10.3, 19.0.0 ≤ v < 19.0.1, 19.04.0 ≤ v < 19.04.31.6.4, 18.10.3, 19.0.1, 19.04.3
centreon centreon_tactical-overview_widgetv < 1.0.3, 18.10.0 ≤ v < 18.10.1, 19.04.0 ≤ v < 19.04.1, 19.10.0 ≤ v < 19.10.11.0.3, 18.10.1, 19.04.1, 19.10.1
centreon centreon_service-monitoring_widgetv < 1.6.4, 18.10.0 ≤ v < 18.10.5, 19.04.0 ≤ v < 19.04.3, 19.10.0 ≤ v < 19.10.21.6.4, 18.10.5, 19.04.3, 19.10.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.