CVE-2020-11017
Medium
Description
In FreeRDP less than or equal to 2.0.0, by providing manipulated input a malicious client can create a double free condition and crash the server. This is fixed in version 2.1.0.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Freerdp
PublishedMay 29, 2020
First seenMay 29, 2020
Weakness typeCWE-415CWE-415
How to fix
Update
- freerdp freerdp2.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| freerdp freerdp | v < 2.1.0 | 2.1.0 |
| opensuse leap | 15.1 | — |
| debian debian_linux | 10.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.