CVE-2020-11020
High
Description
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.
SeverityHigh
CVSS8.5
Exploit probability—
ProductFaye
PublishedApr 29, 2020
First seenApr 29, 2020
Weakness typeCWE-287Improper authentication
How to fix
Update
- faye_project faye1.0.4, 1.1.3, 1.2.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| faye_project faye | 0.5.0 < v < 1.0.4, 1.1.0 ≤ v < 1.1.3, 1.2.0 ≤ v < 1.2.5 | 1.0.4, 1.1.3, 1.2.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.