CVE-2020-11026
Description
In affected versions of WordPress, files with a specially crafted name when uploaded to the Media section can lead to script execution upon accessing the file. This requires an authenticated user with privileges to upload files. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
How to fix
- wordpress wordpress3.7.33, 3.8.33, 3.9.31, 4.0.30, 4.1.30, 4.2.27, 4.3.23, 4.4.22, 4.5.21, 4.6.18, 4.7.17, 4.8.13, 4.9.14, 5.0.9, 5.1.5, 5.2.6, 5.3.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| wordpress wordpress | 3.7 ≤ v < 3.7.33, 3.8 ≤ v < 3.8.33, 3.9 ≤ v < 3.9.31, 4.0 ≤ v < 4.0.30, 4.1 ≤ v < 4.1.30, 4.2 ≤ v < 4.2.27, 4.3 ≤ v < 4.3.23, 4.4 ≤ v < 4.4.22, 4.5 ≤ v < 4.5.21, 4.6 ≤ v < 4.6.18, 4.7 ≤ v < 4.7.17, 4.8 ≤ v < 4.8.13, 4.9 ≤ v < 4.9.14, 5.0 ≤ v < 5.0.9, 5.1 ≤ v < 5.1.5, 5.2 ≤ v < 5.2.6, 5.3 ≤ v < 5.3.3, 5.4 | 3.7.33, 3.8.33, 3.9.31, 4.0.30, 4.1.30, 4.2.27, 4.3.23, 4.4.22, 4.5.21, 4.6.18, 4.7.17, 4.8.13, 4.9.14, 5.0.9, 5.1.5, 5.2.6, 5.3.3 |
| debian debian_linux | 8.0, 9.0, 10.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.