CVE-2020-11041
Description
In FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.
How to fix
- freerdp freerdp2.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| freerdp freerdp | v < 2.1.0 | 2.1.0 |
| opensuse leap | 15.1 | — |
| debian debian_linux | 10.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.