CVE-2020-11048

Low

Description

In FreeRDP after 1.0 and before 2.0.0, there is an out-of-bounds read. It only allows to abort a session. No data extraction is possible. This has been fixed in 2.0.0.

SeverityLow
CVSS2.2
Exploit probability—
ProductFreerdp
PublishedMay 7, 2020
First seenMay 7, 2020

How to fix

Update
  • freerdp freerdp2.0.0 or later

Affected products

ProductAffected versionsFixed in
freerdp freerdp1.0.0 ≤ v < 2.0.02.0.0
canonical ubuntu_linux16.04, 18.04, 19.10, 20.04—
debian debian_linux9.0, 10.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.