CVE-2020-11052

High

Description

In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.

SeverityHigh
CVSS8.3
Exploit probability—
ProductSorcery
PublishedMay 7, 2020
First seenMay 7, 2020
Weakness typeCWE-307CWE-307

How to fix

Update
  • sorcery_project sorcery0.15.0 or later

Affected products

ProductAffected versionsFixed in
sorcery_project sorceryv < 0.15.00.15.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.