CVE-2020-11067
Description
In TYPO3 CMS 9.0.0 through 9.5.16 and 10.0.0 through 10.4.1, it has been discovered that backend user settings (in $BE_USER->uc) are vulnerable to insecure deserialization. In combination with vulnerabilities of third party components, this can lead to remote code execution. A valid backend user account is needed to exploit this vulnerability. This has been fixed in 9.5.17 and 10.4.2.
How to fix
- typo3/cms-core9.5.17, 10.4.2 or later
- typo3/cms10.4.2, 9.5.17 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| typo3 typo3 | 9.0.0 ≤ v ≤ 9.5.16, 10.0.0 ≤ v ≤ 10.4.1 | — |
| typo3/cms-corePackagist | 9.0.0 ≤ v < 9.5.17, 10.0.0 ≤ v < 10.4.2 | 9.5.17, 10.4.2 |
| typo3/cmsPackagist | 10.0.0 ≤ v < 10.4.2, 9.0.0 ≤ v < 9.5.17 | 10.4.2, 9.5.17 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.