CVE-2020-11071

High

Description

SLPJS (npm package slpjs) before version 0.27.2, has a vulnerability where users could experience false-negative validation outcomes for MINT transaction operations. A poorly implemented SLP wallet could allow spending of the affected tokens which would result in the destruction of a user's minting baton. This is fixed in version 0.27.2.

SeverityHigh
CVSS8.6
Exploit probability—
ProductSimpleledger Slpjs
PublishedMay 12, 2020
First seenMay 12, 2020
Weakness typeCWE-697CWE-697

How to fix

Update
  • simpleledger slpjs0.27.2 or later
  • slpjs0.27.2 or later

Affected products

ProductAffected versionsFixed in
simpleledger slpjsv < 0.27.20.27.2
slpjsnpmv < 0.27.20.27.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.