CVE-2020-11076
High
Description
In Puma (RubyGem) before 4.3.4 and 3.12.5, an attacker could smuggle an HTTP response, by using an invalid transfer-encoding header. The problem has been fixed in Puma 3.12.5 and Puma 4.3.4.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Puma
PublishedMay 22, 2020
First seenMay 22, 2020
Weakness typeCWE-444CWE-444
How to fix
Update
- puma puma3.12.6, 4.3.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| puma puma | 3.0.0 ≤ v < 3.12.6, 4.0.0 ≤ v < 4.3.5 | 3.12.6, 4.3.5 |
| fedoraproject fedora | 33 | — |
| debian debian_linux | 9.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.