CVE-2020-11081

Medium

Description

osquery before version 4.4.0 enables a privilege escalation vulnerability. If a Window system is configured with a PATH that contains a user-writable directory then a local user may write a zlib1.dll DLL, which osquery will attempt to load. Since osquery runs with elevated privileges this enables local escalation. This is fixed in version 4.4.0.

SeverityMedium
CVSS5.3
Exploit probability—
ProductLinuxfoundation Osquery
PublishedJul 10, 2020
First seenJul 10, 2020
Weakness typeCWE-114CWE-114

How to fix

Update
  • linuxfoundation osquery4.4.0 or later

Affected products

ProductAffected versionsFixed in
linuxfoundation osqueryv < 4.4.04.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.