CVE-2020-11973

Critical

Description

Apache Camel Netty enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Camel
PublishedMay 14, 2020
First seenMay 14, 2020

How to fix

Update
  • org.apache.camel:camel-netty3.2.0 or later

Affected products

ProductAffected versionsFixed in
apache camel2.22.0 ≤ v ≤ 2.25.0, 3.0.0 ≤ v ≤ 3.1.0—
oracle communications_diameter_signaling_router8.0.0 ≤ v ≤ 8.5.0—
oracle enterprise_manager_base_platform13.3.0.0, 13.4.0.0—
oracle flexcube_private_banking12.0.0, 12.1.0—
org.apache.camel:camel-nettyMaven3.0.0 ≤ v < 3.2.03.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.