CVE-2020-13628
Description
Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web script or HTML via the widgetId parameter to host-monitoring/src/toolbar.php. This vulnerability is fixed in versions 1.6.4, 18.10.3, 19.04.3, and 19.0.1 of the Centreon host-monitoring widget; 1.6.4, 18.10.5, 19.04.3, 19.10.2 of the Centreon service-monitoring widget; and 1.0.3, 18.10.1, 19.04.1, 19.10.1 of the Centreon tactical-overview widget.
How to fix
- centreon centreon_host-monitoring_widget1.6.4, 18.10.3, 19.0.1, 19.04.3 or later
- centreon centreon_tactical-overview_widget1.0.3, 18.10.1, 19.04.1, 19.10.1 or later
- centreon centreon_service-monitoring_widget1.6.4, 18.10.5, 19.04.3, 19.10.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| centreon centreon_host-monitoring_widget | v < 1.6.4, 18.10.0 ≤ v < 18.10.3, 19.0.0 ≤ v < 19.0.1, 19.04.0 ≤ v < 19.04.3 | 1.6.4, 18.10.3, 19.0.1, 19.04.3 |
| centreon centreon_tactical-overview_widget | v < 1.0.3, 18.10.0 ≤ v < 18.10.1, 19.04.0 ≤ v < 19.04.1, 19.10.0 ≤ v < 19.10.1 | 1.0.3, 18.10.1, 19.04.1, 19.10.1 |
| centreon centreon_service-monitoring_widget | v < 1.6.4, 18.10.0 ≤ v < 18.10.5, 19.04.0 ≤ v < 19.04.3, 19.10.0 ≤ v < 19.10.2 | 1.6.4, 18.10.5, 19.04.3, 19.10.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.