CVE-2020-13925
Critical
Description
Similar to CVE-2020-1956, Kylin has one more restful API which concatenates the API inputs into OS commands and then executes them on the server; while the reported API misses necessary input validation, which causes the hackers to have the possibility to execute OS command remotely. Users of all previous versions after 2.3 should upgrade to 3.1.0.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Kylin
PublishedJul 14, 2020
First seenJul 14, 2020
How to fix
Update
- apache kylin3.1.0 or later
- org.apache.kylin:kylin-server-base3.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache kylin | 2.3.0 ≤ v < 3.1.0 | 3.1.0 |
| org.apache.kylin:kylin-server-baseMaven | v < 3.1.0 | 3.1.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.