CVE-2020-13942
Critical
Description
It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Unomi
PublishedNov 24, 2020
First seenNov 24, 2020
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache unomi1.5.2 or later
- org.apache.unomi:unomi1.5.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache unomi | 1.5.0 ≤ v < 1.5.2 | 1.5.2 |
| org.apache.unomi:unomiMaven | v < 1.5.2 | 1.5.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.