CVE-2020-15107

Medium

Description

In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.

SeverityMedium
CVSS5.3
Exploit probability—
ProductOpenenclave
PublishedJul 15, 2020
First seenJul 15, 2020

How to fix

Update
  • openenclave openenclave0.10.0 or later

Affected products

ProductAffected versionsFixed in
openenclave openenclavev < 0.10.00.10.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2020-15107 · Openenclave · Dark Radar