CVE-2020-15138
Description
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
How to fix
- prismjs previewers1.21.0 or later
- prismjs1.21.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| prismjs previewers | 1.1.0 ≤ v < 1.21.0 | 1.21.0 |
| prismjsnpm | 1.1.0 ≤ v < 1.21.0 | 1.21.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.