CVE-2020-15150

Critical

Description

There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.

SeverityCritical
CVSS9.0
Exploit probability—
ProductDuffel Paginator
PublishedSep 1, 2020
First seenSep 1, 2020

How to fix

Update
  • duffel paginator1.0.0 or later

Affected products

ProductAffected versionsFixed in
duffel paginatorv < 1.0.01.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2020-15150 · Duffel Paginator · Dark Radar