CVE-2020-15169
Description
In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.
How to fix
- action_view_project action_view5.2.4.4, 6.0.3.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| action_view_project action_view | v < 5.2.4.4, 6.0.0.0 ≤ v < 6.0.3.3 | 5.2.4.4, 6.0.3.3 |
| debian debian_linux | 10.0 | — |
| fedoraproject fedora | 33 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.