CVE-2020-15210
Description
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
How to fix
- google tensorflow1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 or later
- tensorflow1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 or later
- tensorflow-cpu1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 or later
- tensorflow-gpu1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| google tensorflow | v < 1.15.4, 2.0.0 ≤ v < 2.0.3, 2.1.0 ≤ v < 2.1.2, 2.2.0 ≤ v < 2.2.1, 2.3.0 ≤ v < 2.3.1 | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
| opensuse leap | 15.2 | — |
| tensorflowPyPI | v < 1.15.4, 2.0.0 ≤ v < 2.0.3, 2.1.0 ≤ v < 2.1.2, 2.2.0 ≤ v < 2.2.1, 2.3.0 ≤ v < 2.3.1 | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
| tensorflow-cpuPyPI | v < 1.15.4, 2.0.0 ≤ v < 2.0.3, 2.1.0 ≤ v < 2.1.2, 2.2.0 ≤ v < 2.2.1, 2.3.0 ≤ v < 2.3.1 | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
| tensorflow-gpuPyPI | v < 1.15.4, 2.0.0 ≤ v < 2.0.3, 2.1.0 ≤ v < 2.1.2, 2.2.0 ≤ v < 2.2.1, 2.3.0 ≤ v < 2.3.1 | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.