CVE-2020-15271

Critical

Description

In lookatme (python/pypi package) versions prior to 2.3.0, the package automatically loaded the built-in "terminal" and "file_loader" extensions. Users that use lookatme to render untrusted markdown may have malicious shell commands automatically run on their system. This is fixed in version 2.3.0. As a workaround, the `lookatme/contrib/terminal.py` and `lookatme/contrib/file_loader.py` files may be manually deleted. Additionally, it is always recommended to be aware of what is being rendered with lookatme.

SeverityCritical
CVSS9.3
Exploit probability—
ProductLookatme
PublishedOct 26, 2020
First seenOct 26, 2020

How to fix

Update
  • lookatme_project lookatme2.3.0 or later
  • lookatme2.3.0 or later

Affected products

ProductAffected versionsFixed in
lookatme_project lookatmev < 2.3.02.3.0
lookatmePyPIv < 2.3.02.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.