CVE-2020-15704
Description
The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.
How to fix
- canonical ppp2.4.7-1\+ubuntu1.16.04.3, 2.4.7-2\+2ubuntu1.3, 2.4.7-2\+4.1ubuntu5.1, 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3\+esm2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| canonical ppp | v < 2.4.7-1\+ubuntu1.16.04.3, v < 2.4.7-2\+2ubuntu1.3, v < 2.4.7-2\+4.1ubuntu5.1, v < 2.4.5-5ubuntu1.4, v < 2.4.5-5.1ubuntu2.3\+esm2 | 2.4.7-1\+ubuntu1.16.04.3, 2.4.7-2\+2ubuntu1.3, 2.4.7-2\+4.1ubuntu5.1, 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3\+esm2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.