CVE-2020-1729
Medium
Description
A flaw was found in SmallRye's API through version 1.6.1. The API can allow other code running within the application server to potentially obtain the ClassLoader, bypassing any permissions checks that should have been applied. The largest threat from this vulnerability is a threat to data confidentiality. This is fixed in SmallRye 1.6.2
SeverityMedium
CVSS4.4
Exploit probability—
Product
Redhat Smallrye Config
PublishedMay 28, 2021
First seenMay 28, 2021
Weakness typeCWE-863Incorrect authorization
How to fix
Update
- redhat smallrye_config1.6.2 or later
- io.smallrye.config:smallrye-config1.6.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| redhat smallrye_config | v < 1.6.2 | 1.6.2 |
| io.smallrye.config:smallrye-configMaven | v < 1.6.2 | 1.6.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.