CVE-2020-1737
Description
A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination folder. An attacker could take advantage of this flaw by crafting an archive anywhere in the file system, using a path traversal. This issue is fixed in 2.10.
How to fix
- redhat ansible_engine2.7.17, 2.8.9, 2.9.6 or later
- ansible2.8.9, 2.9.6, 2.7.17 or later
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FWDK3QUVBULS3Q3PQTGEKUQYPSNOU5M3/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QT27K5ZRGDPCH7GT3DRI3LO4IVDVQUB7/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U3IMV3XEIUXL6S4KPLYYM4TVJQ2VNEP2/
- security.gentoo.org/glsa/202006-11
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| redhat ansible_engine | v < 2.7.17, 2.8.0 ≤ v < 2.8.9, 2.9.0 ≤ v < 2.9.6 | 2.7.17, 2.8.9, 2.9.6 |
| redhat ansible_tower | v ≤ 3.3.4, 3.4.0 ≤ v ≤ 3.4.5, 3.5.0 ≤ v ≤ 3.5.5, 3.6.0 ≤ v ≤ 3.6.3 | — |
| ansiblePyPI | 2.8.0a1 ≤ v < 2.8.9, 2.9.0a1 ≤ v < 2.9.6, v < 2.7.17, 2.8.0 ≤ v < 2.8.9, 2.9.0 ≤ v < 2.9.6 | 2.8.9, 2.9.6, 2.7.17 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.